Geopsy: Signal Viewer

From GeopsyWiki
Jump to navigation Jump to search

A Signal viewer is a window in Geopsy allowing to view a set or a subset of signals through a tableIcontable.png, a graphic IconGraphic.png, a map IconMap.png or a chronogram IconChronogram.png . A signal viewer can be created using the View menu and then drag and drop the set of signals of interest in the viewer. Drag and drop signals directly on a signal viewer icon in the toolbar produces the same. When a set or a subset of signals is displayed in a signal viewer (either a table, a graphic, a map or a chronogram) it is possible to perform different actions described hereafter.

Export files

Selecting item export from File menu allows to export the subset of signals of the active signal viewer in various file formats.

Perform basic signal processing

Basic signal processing can be performed on all the signals of the active signal viewer using the menu Waveform.


Perform Advanced Signal processing

Tools are developed as plug-ins and provide specific signal processing. As for basic signal processing, the selected tool is applied to the signals in the active signal viewer. They can be accessed either from Tools menu or from the icons in the toolbar.

Edit files

All menu items in Edit menu apply to all signals contained in the active signal viewer. In particular the following actions are allowed:

  • Editing the metadata in a table
    The metadata of signals in the active Table viewer can be modified in the Edit menu. In order to modify metadata It is necessary to unlock the table edition [Ctrl+K]
  • Sorting signals
    The signals in the active signal viewer can be sorted in the Edit menu
  • Set headers, apply formula to a column
    Set headers for a Table viewer allow to modify the header information by means of generic formulas.
  • Set receivers
    Set receivers allows to modify the coordinates of receivers of all signals in the active signal viewer. The signal names are considered as names of stations to which corresponds only one unique set of coordinates.
  • Creating groups
    A new group can be created with the signals in the active signal viewer.